Back to overview

Investigating Service Degredation

Jun 14 at 01:43am EDT
Affected services
Wordfence Central
Wordfence Website

Resolved
Jun 14 at 01:43am EDT

We are currently investigating a service degradation on www.wordfence.com.

Update 1: As of 6:52 AM UTC, the issue has been resolved