Back to overview

Investigating Outage

Jun 13 at 03:42pm EDT
Affected services
Wordfence Central
Wordfence Website

Resolved
Jun 13 at 03:42pm EDT

We are currently investigating a post upgrade outage. At this time we have no ETA on a recovery.

Update 1: At 4:15pm we identified and resolved the issue affecting the availability of www.wordfence.com. Systems are operational.