Back to overview

Investigating Partial System Outage

Jun 13 at 07:48am EDT
Affected services
Wordfence Central
Wordfence Website

Resolved
Jun 13 at 07:48am EDT

We are currently investigating a partial system outage with www.wordfence.com.

Update 1: Issue has been resolved .