Back to overview
Resolved

Investigating Outage

Jul 24, 2026 at 11:09am UTC
Affected services
Wordfence Plugin
Wordfence Plugin Servers
Wordfence Central
Wordfence Premium Support
Wordfence Website

Resolved
Jul 24, 2026 at 11:09am UTC

We are currently investigating an outage affecting all Wordfence services. We will advise when we have identified the issue.

We had an issue with an upstream provider that is now resolved. All services are back to normal.